Data Delivery Delays

Incident Report for Clearwater Analytics

Resolved

The Clearwater Analytics internal affected systems are fully operational.
Posted Jun 18, 2025 - 10:43 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 10:24 MDT

Identified

Engineers have identified the cause of the issue. They are working on a solution now.
Posted Jun 18, 2025 - 09:15 MDT

Investigating

Clearwater is having an internal systems issue starting 11:21 UTC that may delay client deliverables. Our team has identified the problem and is actively working on resolving the issue.
Posted Jun 18, 2025 - 05:21 MDT
This incident affected: US (Clearwater Analytics website) and EU (Clearwater Analytics website).